Welcome, Guest
Please Login or Register.    Lost Password?

MR2 Mark 1 - Low on power ?
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: MR2 Mark 1 - Low on power ?
#54286
MR2 Mark 1 - Low on power ? 5 Years, 9 Months ago Karma: 0
Just finished restoring a 1986 Toyota MR2 Mark 1 after a very long year. Took it for a test drive last week and it drove like a dream, however just drove it and its not running right, sounds like it 'missing' and very low on power. Have checked the usual (plugs, leads, distributor cap, coil etc) but no joy. Any ideas on what could be the problem?
vob
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
Comments? Suggestions? Register above to have your say!
 
#54289
Re: MR2 Mark 1 - Low on power ? 5 Years, 9 Months ago Karma: 80
maybe a bad earth somewhere?
cozzy90
i hate diesel
Addict
Posts: 1623
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: mallow
<img src="imageshack.us/a/img707/4755/7bn2.jpg" alt="Image Hosted by ImageShack.us"/><br/>
Comments? Suggestions? Register above to have your say!
 
#54295
Re: MR2 Mark 1 - Low on power ? 5 Years, 9 Months ago Karma: 327
Did you do any engine work to it at all since the good drive. Could the distributor have moved and knocked the timing out a little.
slipsliderg
"if it ain't broke don't fix it"
Moderator
Posts: 3977
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Meath Birthday: 04/26
"Happier than a tornado in a trailer park"

"Just as in cuisine, the ‘flavor’ of a car is quite important…”
Hiromu Naruse 1943-2010 RIP
Comments? Suggestions? Register above to have your say!
 
Go to topPage: 1