Welcome, Guest
Please Login or Register.    Lost Password?

Rev 3 Turbo Running problems.
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Rev 3 Turbo Running problems.
#56981
Rev 3 Turbo Running problems. 6 Years, 2 Months ago Karma: 29
Howdy, I've been without my Mr2 since December. the initial issue was that it started running on 3 cylinders. After replacing the Fuel pump resistor it began running on 4 Cylinders again.

Then it starts over fueling, popping, and flames from the exhaust after a few mins.

Then after it warms up the revs keep dropping when idling and it cuts out.

If you drive it it will perform ok, but as soon as you slow down you can see from the tubro timer that the voltage dips and the car cuts out again.

I have replaced the fuel pump resistor twice just in case i got a dodgy one.

I'm out of ideas at this stage and so my mechanic who does not really no Mr2's that well.

Oh the injectors were also replaced with like injectors (540cc)

Anyone got any ideas what the issue could be?
Darc
Thrown in at the deep end
Junior Boarder
Posts: 254
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Kildare, Ireland Birthday: 02/07
Comments? Suggestions? Register above to have your say!
 
#56996
Re: Rev 3 Turbo Running problems. 6 Years, 2 Months ago Karma: 327
Darc wrote:
Oh the injectors were also replaced with like injectors (540cc)


Sorry darc, if you mentioned that yesterday when we were talking. I might not have heard you due to small people shouting at their Dad.

This may be the same thing SPLA had to deal with a couple of weeks ago. Replace the 540's to standard or adjust the duration of the injector pulse to reduce the fuelling quantity. The standard ECU once up to temp tips over to a different fuelling map and seems to drown out the spark plugs from what happened to SPLA.

Injector pulse duration is something that can only be adjusted with aftermarket ECU's AFAIK or perhaps another adjustment can be made to the fuel pressure. I have no practical experience on this though.
slipsliderg
"if it ain't broke don't fix it"
Moderator
Posts: 3977
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Meath Birthday: 04/26
"Happier than a tornado in a trailer park"

"Just as in cuisine, the ‘flavor’ of a car is quite important…”
Hiromu Naruse 1943-2010 RIP
Comments? Suggestions? Register above to have your say!
 
#57003
Re: Rev 3 Turbo Running problems. 6 Years, 2 Months ago Karma: 72
Yeah man sounds similar to the problem i had, try putting stock injectors back in.
I did ask around why this happens though and the answers i got was that the injectors are dirty. im back to my stock rev3 injectors for now and i wanna give the 650cc ones into someone that will be able to clean them and then ill try them again.
spla300
Booooost!!!
Expert Boarder
Posts: 1364
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: longford
Comments? Suggestions? Register above to have your say!
 
#57010
Re: Rev 3 Turbo Running problems. 6 Years, 2 Months ago Karma: 29
www.mr2turbo.info/diff.html
Above link has details on injectors

Thanks for the info. The rev 3 comes with 540cc as stock I beleive. Its been running 540cc injectors for 3 years with no issues.
Darc
Thrown in at the deep end
Junior Boarder
Posts: 254
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Kildare, Ireland Birthday: 02/07
Comments? Suggestions? Register above to have your say!
 
Go to topPage: 1