Welcome, Guest
Please Login or Register.    Lost Password?

Passenger door power window not working.
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Passenger door power window not working.
#78611
Passenger door power window not working. 1 Year, 7 Months ago Karma: 2
Hi, Here with another Problem. When I bought the car last week, the seller told me about the passenger door window not working, the Switch was broken inside so I ordered a new one from Toyota. Today it came, I fitted it and nothing happened.
I was wondering if the Problem was more than the Switch as I thought the Driver side switch should operate the window but it didnt.
I have the wiring diagram. I assume the Power window relay is ok as the Drivers side works ok. The lock Switch in the window master Switch could be at fault so i think I should take the Drivers side out. Any other Things I should look for. It could be the supply to the Motor on the passenger side.
einsvonzehn
Fresh Boarder
Posts: 7
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Spain and Austria Birthday: 04/13
Comments? Suggestions? Register above to have your say!
 
#78617
Re: Passenger door power window not working. 1 Year, 7 Months ago Karma: 28
If you can hear the motor, then it's probably the regulator.
Failing that, I would connect up a battery to the window motor to see if that is working.
If the motor is spinning, then you need to look at the door wiring loom, wires can often break at the point where it bends when opening/closing the door ... going from the door to the door frame
Mister2
Rev3 T-Bar Turbo
Senior Boarder
Posts: 464
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Limerick
Comments? Suggestions? Register above to have your say!
 
#78621
Re: Passenger door power window not working. 1 Year, 7 Months ago Karma: 2
Thanks for your Suggestion, I did have a break in a wire by the door but it was to the Speaker. There was no power to the window and when I checked the lock window Switch it was jammmed. I rectified that and it now works. Thanks again.
einsvonzehn
Fresh Boarder
Posts: 7
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Spain and Austria Birthday: 04/13
Comments? Suggestions? Register above to have your say!
 
Go to topPage: 1